090731 初「なでしこ」

今日パソコンが3回ほどダウン。
いちいち動いているか見に行くのも、Pingでチェックするのも面倒くさい
ので、なでしこで自動化。ぺんちゃんは、「ひまわり」を使ったことがある
ので最初は「ひまわり」でと思っていたけどping機能を「なでしこ」が持って
いたので「なでしこ」で。
「ひまわり」の新バージョンが「なでしこ」なので専用画面から部品
(コマンド)をマウスで移動させて作るけど、微妙に文法が違ってた。
で、できたプログラムがこれ。

=====(ソース)======================

母艦は「 死活監視」
母艦のW=250
母艦のH=10
HOSTは「192.168.1.40」
▲ 開始
HOSTへPING
結果1=それ
5秒待つ。
HOSTへPING
結果2=それ
結果=結果1+結果2
「{今} {結果1}+{結果2}={結果}」と表示。
もし、結果=0 ならば
   異常に飛ぶ。
違えば 600秒待つ。
開始に飛ぶ。
▲ 異常
母艦は「 異常発生」
「{今} Pingが続けてエラーになりました。」と表示。
「{今} Pingが続けてエラーになりました。確認してください。」と言う。
終わり
=================================

HOSTにpingを5秒間隔で2回行い、2回ともエラーだと異常。
1回でも成功すると10分後にまた確認する、と言うシンプルなもの。
実行形式(.exe)に変換して出来上がり。
「それ」は結果が入る箱で、Pingに失敗すると0が入る。なので、
結果を2つ足して0だと異常。
{今}は、今の時間。
母艦は画面表示の窓なので、「タイトル」を付けた。
日本語なんで、なでしこのこのページを読むとより深くわかるかも。
って別に読まなくってもわかると思う。部品をマウスでつかむと1行ヘルプが
でるので、それを見ながらぺんちゃんは作った。

090731 停電


昨日も停電の書き込みしたけど、今日はぺんちゃんが乗ってた電車が停電。発車間際でいきなり電灯が消え、ちょっとハラハラ。スグに駅のブザーが鳴りだし、うるさい。車掌さん・駅員さんの放送も混乱気味。しばらくして振替の案内が始まり、どうしょうかな?と思ってたら通電されたけどまた停電。また通電で、振替券をもらう列に並んでたら電車が動き出した。振替券をもらったけど、ぺんちゃんは都バス定期があるのでバスで会社へ。約5分遅刻で済んだ。で会社の人に意外と早かったけど、どう来たの?と聞かれて「都バス乗継ぎ」って答えたら、あきらめ気味に普通バス乗継ぎで来ないだろ…。(地下鉄で大廻りするよりバスでショートカットした方が早いし、駅で歩かないので路線網を把握していれば、バスが普通だと思うけど。)

<xfyBlogEditorで追加>


右往左往する乗客の皆さん。いい具合に手ぶれしてますが・・・。
途中駅で特急に乗り換えたけど最初に乗ってた普通車もやってきた。


とりあえずもらってみたものの・・・・